Service Background Jobs seems to be down

Minor incident Background Jobs
59 minutes, 36 seconds

Updates

Resolved

Service is back up.

January 2, 2020 · 13:31 UTC
Issue

Due to a networking issue at the data center we’re hosted at, some services may be slower to respond or update than normal.

January 2, 2020 · 12:31 UTC