Service Website seems to be down

Major incident Website
3 hours, 42 minutes, 39 seconds

Updates

Resolved

After investigation this issue was a result of the Cloudflare Root Certificate expiring today at 2019-11-14T01:43:50Z. Recovery took several hours as we had no staff available who could resolve this issue until 4:37AM London Time.

November 14, 2019 · 05:30 UTC
Resolved

Service is back up.

November 14, 2019 · 05:19 UTC
Issue

Our monitoring system has found out the service Website is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 14, 2019 · 01:48 UTC