Service Website seems to be down

Major Incident Website
2 minutes

Update

Resolved

Service is back up.

September 14th, 2019 at 23:41 UTC
Issue

Our monitoring system has found out the service Website is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 14th, 2019 at 23:39 UTC