Service Website seems to be down

Major incident Website
54 minutes, 11 seconds

Updates

Resolved

Service is back up.

August 19, 2019 · 17:10 UTC
Issue

Our monitoring system has found out the service Website is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

August 19, 2019 · 16:16 UTC