Datacenter outage

Major incident Author Analytics Background Jobs Website
34 minutes, 2 seconds

Updates

Resolved

The website is back online

August 18, 2020 · 17:09 UTC
Issue

There seems to be an outage at the datacenter Royal Road is hosted at. We are currently waiting for further information from the datacenter

August 18, 2020 · 16:37 UTC

← Back